Broken Upload Functionality with Latest Cloudsmith API Release
Resolved·Partial outage

The 2.0.8 release of the cloudsmith-api bindings for Python has been yanked from PyPi. Affected users can clear local pip caches to ensure a fresh pull of 2.0.7 takes place following this. We apologise profusely for this erroneous release of the bindings.

Wed, Feb 14, 2024, 03:28 PM
(1 year ago)
·
Affected components
Updates

Resolved

The 2.0.8 release of the cloudsmith-api bindings for Python has been yanked from PyPi. Affected users can clear local pip caches to ensure a fresh pull of 2.0.7 takes place following this. We apologise profusely for this erroneous release of the bindings.

Wed, Feb 14, 2024, 03:28 PM

Identified

We've identified a problem the latest release of the Cloudsmith API bindings, when interacting with the Cloudsmith CLI. We're working on resolving this ASAP. Affected users can temporarily downgrade to cloudsmith API 2.0.7 whilst this is being resolved. Non-upload functionality remains operational with the latest release. Apologies to all those affected.

Wed, Feb 14, 2024, 03:23 PM