We believe in being transparent and over-communicating status in minor detail where possible.
Availability metrics are reported at an aggregate level across all tiers, regions, and package formats.
Each customer's experience varies depending on workflows, workload, settings, and the features in use.
The issue has now been resolved, and package caching to the repositories has resumed.
Packages pulled between 17:00 and 18:45 UTC will be missing from the repositories. These missing packages will be cached during subsequent pulls.
Note: Package caching to the repositories was impacted. Package pulls remained unaffected throughout the incident. Webhooks subscribed to the Package Downloaded event were also impacted during this period, and missed events will not be replayed.
Resolved
The issue has now been resolved, and package caching to the repositories has resumed.
Packages pulled between 17:00 and 18:45 UTC will be missing from the repositories. These missing packages will be cached during subsequent pulls.
Note: Package caching to the repositories was impacted. Package pulls remained unaffected throughout the incident. Webhooks subscribed to the Package Downloaded event were also impacted during this period, and missed events will not be replayed.
Identified
We have identified the cause of new upstream packages not appearing in repositories globally and are applying a fix to restore package syncing. We will post our next update by 19:08 UTC.
Investigating
We are continuing to investigate reports of new upstream packages not appearing in repositories globally. There is no material change since our last update. We will post our next update by 19:00 UTC.
Please note that the packages caching and webhooks subscribed to Package Downloaded event are impacted.
Packages pull was not impacted.
Investigating
We are investigating reports of new upstream packages not appearing in repositories, starting from approximately 17:00 UTC. We will post our next update by 18:30 UTC.