Resolved
We can confirm the issue has been resolved.
Monitoring
The elevated download errors have been resolved, and all systems are running normally.
Impact Windows (UTC):
us-west: 16:35 – 16:47
us-east: 17:02 – 17:03
Investigating
We’re seeing an increase in error rates in the US region. Our engineers are investigating the cause.