Resolved
This issue has now been resolved.
Monitoring
On Friday May 1st 2026, Cloudsmith introduced PEP 658-compliant metadata to Python indexes. Packages uploaded prior to this functionality being introduced (excluding upstream packages) were unable to have this metadata fetched.
Package downloads themselves remained unaffected. However, Python-native clients such as uv and newer versions of pip treat metadata fetch failures as general failures, and refused to download the affected artifacts. Upstream fetches, non-wheel artifacts, and newly uploaded wheels were unaffected. For affected packages, the result was failed Python installs.
We've now removed these metadata URLs from Python indexes while we backfill the data for packages that were missing it. Affected installs should now succeed on retry.
We sincerely apologize for the disruption.