Resolved
The issues causing increased latency and error rates in the EU West region have been resolved.
Monitoring
The issues causing increased latency in the EU West region have been mitigated. Service has been restored, and we are continuing to monitor the system health
Investigating
We are seeing an increase in request times in the EU West region. API and Web UI requests were impacted, with errors observed between 09:58 and 10:04. Our engineers are currently investigating.