Resolved
The issues causing increased latency in the US East 2 region have been resolved.
Monitoring
Our engineers have identified the issue causing increased request latency in US East 2 and have implemented a fix. We are seeing request latency returning to normal levels. We continue to monitor the system.
Investigating
Our engineers are continuing to investigate an issue causing increased latency for requests from the US East 2 region.
Investigating
We are investigating an issue causing increased latency for requests from customers in the US East 2 region. You may experience failure with authentication and slow request performance.